upgrader 2.7.3
upgrader: ^2.7.3

Flutter Android iOS

Flutter package for prompting users to upgrade when there is a newer version of the app in the store.

158
likes
100 / 110
pub points
93 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 122 out of 201 API elements (60.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:upgrader/upgrader.dart that imports:
  • package:upgrader/src/upgrader.dart that imports:
  • package:upgrader/src/appcast.dart that imports:
  • package:device_info/device_info.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
device_info>=0.4.1 <1.1.01.0.01.0.0
flutter_device_locale^0.4.00.4.00.4.0
http^0.12.00.12.20.12.2
package_info>=0.4.0+3 <2.0.00.4.3+20.4.3+2
shared_preferences^0.5.20.5.12+40.5.12+4
url_launcher^5.0.25.7.105.7.10
version^1.2.01.2.01.2.0
xml>=3.5.0 <5.0.04.5.14.5.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
device_info_platform_interface-1.0.11.0.1
ffi-0.1.30.1.3
file-5.2.15.2.1
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
shared_preferences_linux-0.0.2+40.0.2+4
shared_preferences_macos-0.0.1+110.0.1+11
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+30.0.1+3
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
url_launcher_linux-0.0.1+40.0.1+4
url_launcher_macos-0.0.1+90.0.1+9
url_launcher_platform_interface-1.0.91.0.9
url_launcher_web-0.1.5+10.1.5+1
url_launcher_windows-0.0.1+30.0.1+3
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

158
likes
100
pub points
93%
popularity

Publisher

larryaasen.com

Flutter package for prompting users to upgrade when there is a newer version of the app in the store.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

device_info, flutter, flutter_device_locale, http, package_info, shared_preferences, url_launcher, version, xml

More

Packages that depend on upgrader