test_api 0.2.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 89

test_api #

This is a a minimal package for writing tests. At this time this package is not intended to be publicly used as the API will take time to stabilize.

0.2.2 #

  • Require Dart SDK >=2.1.0.

0.2.1 #

  • Add remote_listener.dart and suite_channel_manager.dart.

0.2.0 #

  • Remove "runner" extensions.

0.1.1 #

  • Update stack_trace_formatter to fold test_api frames by default.

0.1.0 #

  • Initial release of test_api. Provides the basic API for writing tests and touch points for implementing a custom test runner.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  test_api: ^0.2.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:test_api/test_api.dart';
  
Version Uploaded Documentation Archive
0.2.2 Jan 18, 2019 Go to the documentation of test_api 0.2.2 Download test_api 0.2.2 archive
0.2.1 Nov 5, 2018 Go to the documentation of test_api 0.2.1 Download test_api 0.2.1 archive
0.2.0 Nov 1, 2018 Go to the documentation of test_api 0.2.0 Download test_api 0.2.0 archive
0.1.1 Oct 30, 2018 Go to the documentation of test_api 0.1.1 Download test_api 0.1.1 archive
0.1.0 Oct 26, 2018 Go to the documentation of test_api 0.1.0 Download test_api 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
95
Health:
Code health derived from static analysis. [more]
91
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
89
Learn more about scoring.

We analyzed this package on Mar 6, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: Flutter, other

Primary library: package:test_api/test_api.dart with components: isolate.

Health suggestions

Fix lib/src/frontend/throws_matchers.dart. (-5.36 points)

Analysis of lib/src/frontend/throws_matchers.dart reported 11 hints, including:

line 12 col 5: 'Throws' is deprecated and shouldn't be used.

line 17 col 5: 'Throws' is deprecated and shouldn't be used.

line 22 col 5: 'Throws' is deprecated and shouldn't be used.

line 27 col 5: 'Throws' is deprecated and shouldn't be used.

line 32 col 5: 'Throws' is deprecated and shouldn't be used.

Fix lib/src/frontend/expect.dart. (-2.48 points)

Analysis of lib/src/frontend/expect.dart reported 5 hints:

line 59 col 47: 'ErrorFormatter' is deprecated and shouldn't be used.

line 84 col 5: 'ErrorFormatter' is deprecated and shouldn't be used.

line 90 col 12: 'formatFailure' is deprecated and shouldn't be used.

line 129 col 12: 'formatFailure' is deprecated and shouldn't be used.

line 135 col 14: 'formatFailure' is deprecated and shouldn't be used.

Fix lib/src/frontend/async_matcher.dart. (-0.50 points)

Analysis of lib/src/frontend/async_matcher.dart reported 1 hint:

line 43 col 16: 'formatFailure' is deprecated and shouldn't be used.

Fix lib/src/frontend/throws_matcher.dart. (-0.50 points)

Analysis of lib/src/frontend/throws_matcher.dart reported 1 hint:

line 41 col 5: 'Throws' is deprecated and shouldn't be used.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and test_api.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
async >=1.13.0 <3.0.0 2.0.8
boolean_selector ^1.0.0 1.0.4
collection ^1.8.0 1.14.11
matcher >=0.12.3 <0.12.4 0.12.3+1 0.12.4
meta ^1.1.5 1.1.7
path ^1.2.0 1.6.2
pedantic ^1.0.0 1.5.0
source_span ^1.4.0 1.5.5
stack_trace ^1.9.0 1.9.3
stream_channel ^1.6.0 1.6.8
string_scanner >=0.1.1 <2.0.0 1.0.4
term_glyph ^1.0.0 1.1.0
Transitive dependencies
charcode 1.1.2
Dev dependencies
fake_async >=0.1.2 <2.0.0
test >=0.1.0 <2.0.0
test_core >=0.1.0 <2.0.0
test_descriptor ^1.0.0
test_process ^1.0.0