skawa_material_components 1.1.0+1
skawa_material_components: ^1.1.0+1

Dart js
Flutter web

Additional Material Design components for AngularDart. Complements the official `angular_components` package.

6
likes
70 / 110
pub points
78 %
popularity

We analyzed this package on Nov 14, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 38 out of 243 API elements (15.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:skawa_material_components/base_implementations/grid/grid.dart that imports:
  • dart:html
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/base_implementations/grid/grid.dart:18:12

   ╷
18 │     return new _DomGridTile(gridTile);
   │            ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/base_implementations/grid/grid.dart

INFO: Unnecessary new keyword.

lib/base_implementations/grid/grid.dart:72:12

   ╷
72 │     return new GridUpdate(tileTransformations, newGridHeight);
   │            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/base_implementations/grid/grid.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular^5.3.05.3.16.0.1
angular_components^0.13.00.13.0+11.0.2
quiver^2.0.32.1.52.1.5
sass_builder^2.1.22.1.32.1.3
Transitive dependencies
PackageConstraintCompatibleLatest
analyzer-0.35.40.41.0
angular_ast-0.5.91.0.1
angular_compiler-0.4.31.0.1
angular_forms-2.1.23.0.0
args-1.6.01.6.0
async-2.4.22.4.2
build-1.5.01.5.0
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_repl-0.2.0+10.2.0+1
code_builder-3.5.03.5.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.14.6+10.16.2
dart_internal-0.1.12-nullsafety.10.1.12-nullsafety.1
dart_style-1.2.41.3.9
fixnum-0.10.110.10.11
front_end-0.1.140.1.29
glob-1.2.01.2.0
http-0.12.20.12.2
http_parser-3.1.43.1.4
intl-0.15.80.16.1
js-0.6.20.6.2
json_annotation-3.1.03.1.0
kernel-0.3.140.3.29
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.2.31.2.3
node_interop-1.2.01.2.0
node_io-1.1.11.1.1
observable-0.22.20.22.2
package_config-1.9.31.9.3
package_resolver-1.0.101.0.10
path-1.7.01.7.0
pedantic-1.9.21.9.2
protobuf-0.13.16+11.1.0
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
sass-1.29.01.29.0
source_gen-0.9.4+40.9.8
source_maps-0.10.90.10.9
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
stream_transform-1.2.01.2.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.3.0` on angular does not support the latest published version `6.0.1`

pubspec.yaml:15:12

   ╷
15 │   angular: ^5.3.0
   │            ^^^^^^
   ╵
The constraint `^0.13.0` on angular_components does not support the latest published version `1.0.2`

pubspec.yaml:16:23

   ╷
16 │   angular_components: ^0.13.0
   │                       ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

6
likes
70
pub points
78%
popularity

Additional Material Design components for AngularDart. Complements the official `angular_components` package.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

tams.harsnyi@gmail.com

License

MIT (LICENSE)

Dependencies

angular, angular_components, quiver, sass_builder

More

Packages that depend on skawa_material_components