js 0.6.1+1

  • Readme
  • Changelog
  • Installing
  • 79

Methods and annotations to specify interoperability with JavaScript APIs.

This packages requires Dart SDK 1.13.0.

This is beta software. Please files issues.

Adding the dependency #

Add the following to your pubspec.yaml:

  js: ^0.6.0

Example #

See the Chart.js Dart API for an end-to-end example.

Usage #

Calling methods

// Calls invoke JavaScript `JSON.stringify(obj)`.
external String stringify(obj);

Classes and Namespaces

library maps;

import "package:js/js.dart";

// Invokes the JavaScript getter `google.maps.map`.
external Map get map;

// `new Map` invokes JavaScript `new google.maps.Map(location)`
class Map {
  external Map(Location location);
  external Location getLocation();

// `new Location(...)` invokes JavaScript `new google.maps.LatLng(...)`
// We recommend against using custom JavaScript names whenever
// possible. It is easier for users if the JavaScript names and Dart names
// are consistent.
class Location {
  external Location(num lat, num lng);

JavaScript object literals

Many JavaScript APIs take an object literal as an argument. For example:

// JavaScript
printOptions({responsive: true});

If you want to use printOptions from Dart, you cannot simply pass a Dart Map object – they are "opaque" in JavaScript.

Instead, create a Dart class with both the @JS() and @anonymous annotations.

// Dart
void main() {
  printOptions(new Options(responsive: true));

external printOptions(Options options);

class Options {
  external bool get responsive;

  external factory Options({bool responsive});

NB: This anonymous class must have an unnamed factory constructor.

Passing functions to JavaScript.

If you are passing a Dart function to a JavaScript API, you must wrap it using allowInterop or allowInteropCaptureThis.

Contributing and Filing Bugs #

Please file bugs and features requests on the Github issue tracker.

We also love and accept community contributions, from API suggestions to pull requests. Please file an issue before beginning work so we can discuss the design and implementation. We are trying to create issues for all current and future work, so if something there intrigues you (or you need it!) join in on the discussion.

Code contributors must sign the Google Individual Contributor License Agreement.

0.6.1+1 #

  • Support Dart 2 final release.

0.6.1 #

  • Add js_util library of utility methods to efficiently manipulate typed JavaScript interop objects in cases where the member name is not known statically.

0.6.0 #

  • Version 0.6.0 is a complete rewrite of package:js.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  js: ^0.6.1+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:js/js.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 5, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev

Health suggestions

Fix lib/src/varargs.dart. (-1 points)

Analysis of lib/src/varargs.dart reported 2 hints:

line 37 col 20: Avoid const keyword.

line 61 col 9: Unnecessary new keyword.

Fix lib/js.dart. (-0.50 points)

Analysis of lib/js.dart reported 1 hint:

line 32 col 30: Avoid const keyword.

Maintenance suggestions

Package is getting outdated. (-88.22 points)

The package was last published 98 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0-dev.0.0 <3.0.0