firebase_storage 0.1.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 50

Firebase Cloud Storage for Flutter #

pub package

A Flutter plugin to use the Firebase Cloud Storage API.

For Flutter plugins for other Firebase products, see FlutterFire.md.

Note: This plugin is still under development, and some APIs might not be available yet. Feedback and Pull Requests are most welcome!

Usage #

To use this plugin, add firebase_storage as a dependency in your pubspec.yaml file.

Getting Started #

See the example directory for a complete sample app using Firebase Cloud Storage.

0.1.2 #

  • Added StorageReference delete function to remove files from Firebase.

0.1.1 #

  • Simplified and upgraded Android project template to Android SDK 27.
  • Updated package description.

0.1.0 #

  • Breaking change. Upgraded to Gradle 4.1 and Android Studio Gradle plugin 3.0.1. Older Flutter projects need to upgrade their Gradle setup as well in order to use this version of the plugin. Instructions can be found here.
  • Relaxed GMS dependency to [11.4.0,12.0[

0.0.8 #

  • Added FLT prefix to iOS types
  • Change GMS dependency to 11.4.+

0.0.7 #

  • Change GMS dependency to 11.+

0.0.6 #

  • Added StorageReference getData function to download files into memory.

0.0.5+1 #

  • Aligned author name with rest of repo.

0.0.5 #

  • Updated to Firebase SDK to always use latest patch version for 11.0.x builds
  • Fix crash when encountering upload failure

0.0.4 #

  • Updated to Firebase SDK Version 11.0.1

0.0.3 #

  • Suppress unchecked warnings

0.0.2 #

  • Bumped buildToolsVersion to 25.0.3
  • Updated README

0.0.1 #

  • Initial Release

example/lib/main.dart

// Copyright 2017 The Chromium Authors. All rights reserved.
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.

import 'dart:async';
import 'dart:io';
import 'dart:math';

import 'package:flutter/material.dart';
import 'package:firebase_storage/firebase_storage.dart';
import 'package:http/http.dart' as http;

void main() {
  runApp(new MyApp());
}

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Flutter Storage Example',
      home: new MyHomePage(),
    );
  }
}

class MyHomePage extends StatefulWidget {
  @override
  _MyHomePageState createState() => new _MyHomePageState();
}

const String kTestString = "Hello world!";

class _MyHomePageState extends State<MyHomePage> {
  String _fileContents;

  Future<Null> _uploadFile() async {
    final Directory systemTempDir = Directory.systemTemp;
    final File file = await new File('${systemTempDir.path}/foo.txt').create();
    file.writeAsString(kTestString);
    assert(await file.readAsString() == kTestString);
    final String rand = "${new Random().nextInt(10000)}";
    final StorageReference ref =
        FirebaseStorage.instance.ref().child("foo$rand.txt");
    final StorageUploadTask uploadTask = ref.put(file);
    final Uri downloadUrl = (await uploadTask.future).downloadUrl;
    final http.Response downloadData = await http.get(downloadUrl);
    setState(() {
      _fileContents = downloadData.body;
    });
  }

  @override
  Widget build(BuildContext context) {
    return new Scaffold(
      appBar: new AppBar(
        title: const Text('Flutter Storage Example'),
      ),
      body: new Center(
        child: new Column(
          mainAxisSize: MainAxisSize.min,
          children: <Widget>[
            _fileContents == null
                ? const Text('Press the button to upload a file')
                : new Text(
                    'Success!\n\nFile contents: "$_fileContents"',
                    style: const TextStyle(
                        color: const Color.fromARGB(255, 0, 155, 0)),
                  )
          ],
        ),
      ),
      floatingActionButton: new FloatingActionButton(
        onPressed: _uploadFile,
        tooltip: 'Upload',
        child: new Icon(Icons.file_upload),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_storage: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_storage/firebase_storage.dart';
  
Version Uploaded Documentation Archive
3.0.2 Jun 19, 2019 Go to the documentation of firebase_storage 3.0.2 Download firebase_storage 3.0.2 archive
3.0.1 Jun 4, 2019 Go to the documentation of firebase_storage 3.0.1 Download firebase_storage 3.0.1 archive
3.0.0 May 7, 2019 Go to the documentation of firebase_storage 3.0.0 Download firebase_storage 3.0.0 archive
2.1.1+2 May 2, 2019 Go to the documentation of firebase_storage 2.1.1+2 Download firebase_storage 2.1.1+2 archive
2.1.1+1 Apr 29, 2019 Go to the documentation of firebase_storage 2.1.1+1 Download firebase_storage 2.1.1+1 archive
2.1.0+1 Feb 25, 2019 Go to the documentation of firebase_storage 2.1.0+1 Download firebase_storage 2.1.0+1 archive
2.1.0 Feb 21, 2019 Go to the documentation of firebase_storage 2.1.0 Download firebase_storage 2.1.0 archive
2.0.1+1 Feb 15, 2019 Go to the documentation of firebase_storage 2.0.1+1 Download firebase_storage 2.0.1+1 archive
2.0.1 Feb 8, 2019 Go to the documentation of firebase_storage 2.0.1 Download firebase_storage 2.0.1 archive
2.0.0 Jan 28, 2019 Go to the documentation of firebase_storage 2.0.0 Download firebase_storage 2.0.0 archive

All 42 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
99
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0