Firebase Realtime Database for Flutter #
A Flutter plugin to use the Firebase Realtime Database API.
For Flutter plugins for other Firebase products, see README.md.
To use this plugin, add
firebase_database as a dependency in your pubspec.yaml file.
Getting Started #
example directory for a complete sample app using Firebase Realtime Database.
- Fix possible NullPointerException when plugin is registered without a valid Activity.
- Update documentation to reflect new repository location.
- Update unit tests to call
- Remove executable bit on LICENSE file.
- Update google-services Android gradle plugin to 4.3.0 in documentation and examples.
- Updated transactions implementation on Android for compatibility with newer versions of Flutter engine that require channel calls be made on the UI thread.
- Automatically use version from pubspec.yaml when reporting usage to Firebase.
- Add missing template type parameter to
- Bump minimum Flutter version to 1.5.0.
- Suppress deprecation warning for BinaryMessages. See: https://github.com/flutter/flutter/issues/33446
- Update Android dependencies to latest.
- Provide a
- Added an integration test for transactions.
- Fix the issue that
getDictionaryFromErroralways returns non nil result even when the parameter is nil.
- Fixing DatabaseReference.set unhandled exception which happened when a successful operation was performed.
- Log messages about automatic configuration of the default app are now less confusing.
- Remove categories.
- Log a more detailed warning at build time about the previous AndroidX migration.
Breaking change. Migrate from the deprecated original Android Support Library to AndroidX. This shouldn't result in any functional changes, but it requires any Android apps using this plugin to also migrate if they're using the original support library.
This was originally incorrectly pushed in the
- Revert the breaking 1.1.0 update. 1.1.0 was known to be breaking and
should have incremented the major version number instead of the minor. This
revert is in and of itself breaking for anyone that has already migrated
however. Anyone who has already migrated their app to AndroidX should
immediately update to
2.0.0instead. That's the correctly versioned new push of
BAD. This was a breaking change that was incorrectly published on a minor version upgrade, should never have happened. Reverted by 1.1.0+1.
"Breaking change. Migrate from the deprecated original Android Support Library to AndroidX. This shouldn't result in any functional changes, but it requires any Android apps using this plugin to also migrate if they're using the original support library."
- Bumped Android dependencies to latest.
- Bumped test and mockito versions to pick up Dart 2 support.
- Bump Android and Firebase dependency versions.
- Updated Gradle tooling to match Android Studio 3.1.2.
- Bump to released version
- Allow null value for
equalToqueries on Android.
- Updated Google Play Services dependencies to version 15.0.0.
- Updated firebase_core dependency to ^0.2.2
- Simplified podspec for Cocoapods 1.5.0, avoiding link issues in app archives.
- Fixes Dart 2 runtime cast error.
- Breaking change. Set SDK constraints to match the Flutter beta release.
- Fixed Dart 2 type errors.
- Enabled use in Swift projects.
- Allow null values for Query startAt, endAt, and equalTo
- Support to specify a database by URL if required
- Fix warnings from the Dart 2.0 analyzer.
- Simplified and upgraded Android project template to Android SDK 27.
- Updated package description.
- Fix function name collision when using Firebase Database and Cloud Firestore together on iOS.
- Breaking change. Upgraded to Gradle 4.1 and Android Studio Gradle plugin 3.0.1. Older Flutter projects need to upgrade their Gradle setup as well in order to use this version of the plugin. Instructions can be found here.
- Support for multiple databases, new dependency on firebase_core
- Relax GMS dependency to 11.+
- Add FLT prefix to iOS types
- Avoid error when clearing FirebaseSortedList
- Fix memory leak in FirebaseAnimatedList
- Change GMS dependency to 11.4.+
- Change GMS dependency to 11.+
- Add RTDB transaction support.
- Aligned author name with rest of repo.
- Breaking Change: Added current list index to the type signature of itemBuilder for FirebaseAnimatedList.
- Fix FirebaseSortedList to show data changes.
- Fixed lingering value/child listeners.
- Updated to Firebase SDK to always use latest patch version for 11.0.x builds
- Fixes startAt/endAt on iOS when used without a key
- Added workaround for inconsistent numeric types when using keepSynced on iOS
- Bug fixes to Query handling
- Updated to Firebase SDK Version 11.0.1
- Added missing offline persistence and query functionality on Android
- Fixed startAt query behavior on iOS
- Persistence methods no longer throw errors on failure, return false instead
- Updates to docs and tests
- Fixed offline persistence on iOS
- Various APIs added to FirebaseDatabase and Query
- Added removal and priority to DatabaseReference
- Improved documentation
- Added unit tests
- Fixed analyzer warnings
- Removed stub code and replaced it with support for more event types, paths, auth
- Improved example
- Updated README.md
- Bumped buildToolsVersion to 25.0.3
- Added example app
- Fix compilation error
- Initial Release
Demonstrates how to use the firebase_database plugin.
Getting Started #
For help getting started with Flutter, view our online documentation.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: firebase_database: ^3.0.7
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Oct 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.5.1
- pana: 0.12.21
- Flutter: 1.9.1+hotfix.4
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
|Dart SDK||>=2.0.0-dev.28.0 <3.0.0|