firebase_core 0.4.3+2

Flutter Android iOS web

Flutter plugin for Firebase Core, enabling connecting to multiple Firebase apps.

402
likes
100 / 110
pub points
100 %
popularity

We analyzed this package on Oct 21, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 11 API elements (63.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, Web
Package does not support Flutter platform Linux

Because:

  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, Web
Package does not support Flutter platform macOS

Because:

  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core_platform_interface^1.0.01.0.42.0.0
firebase_core_web^0.1.10.1.1+20.2.0
flutterflutter0.0.00.0.0
meta^1.0.51.3.0-nullsafety.31.3.0-nullsafety.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.3
charcode-1.1.31.2.0-nullsafety.1
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
firebase-7.3.27.3.2
flutter_web_plugins-0.0.00.0.0
http-0.12.20.12.2
http_parser-3.1.43.1.4
js-0.6.20.6.2
matcher-0.12.90.12.10-nullsafety.1
path-1.7.01.8.0-nullsafety.1
pedantic-1.9.21.9.2
plugin_platform_interface-1.0.31.0.3
quiver-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.2
stack_trace-1.9.51.10.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.1
term_glyph-1.1.01.2.0-nullsafety.1
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on firebase_core_platform_interface does not support the latest published version `2.0.0`

pubspec.yaml:19:37

   ╷
19 │   firebase_core_platform_interface: ^1.0.0
   │                                     ^^^^^^
   ╵
The constraint `^0.1.1` on firebase_core_web does not support the latest published version `0.2.0`

pubspec.yaml:28:22

   ╷
28 │   firebase_core_web: ^0.1.1
   │                      ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

402
likes
100
pub points
100%
popularity

Publisher

firebase.google.com

Flutter plugin for Firebase Core, enabling connecting to multiple Firebase apps.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

firebase_core_platform_interface, firebase_core_web, flutter, meta

More

Packages that depend on firebase_core