dart_internal 0.1.10

This package is not intended for wide use. It provides a temporary API to solve the problem: "Given an object some generic type A, how do I construct an instance of generic type B with the same type a

0
likes
10 / 110
pub points
93 %
popularity

We analyzed this package on Oct 20, 2020, and awarded it 10 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Sdk-constraint doesn't allow future stable dart 2.x releases

pubspec.yaml:19:8

   ╷
19 │   sdk: ">=2.0.0 <2.10.0"
   │        ^^^^^^^^^^^^^^^^^
   ╵
The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: The library 'dart:_internal' is internal and can't be imported.

lib/extract_type_arguments.dart:13:8

   ╷
13 │ import 'dart:_internal' as internal;
   │        ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/extract_type_arguments.dart

Support up-to-date dependencies
0 / 20

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 2.10.2. Cannot run `pub outdated`.

pubspec.yaml:19:8

   ╷
19 │   sdk: ">=2.0.0 <2.10.0"
   │        ^^^^^^^^^^^^^^^^^
   ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 2.10.2.

pubspec.yaml:19:8

   ╷
19 │   sdk: ">=2.0.0 <2.10.0"
   │        ^^^^^^^^^^^^^^^^^
   ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (2.10.2)

pubspec.yaml:19:8

   ╷
19 │   sdk: ">=2.0.0 <2.10.0"
   │        ^^^^^^^^^^^^^^^^^
   ╵
0
likes
10
pub points
93%
popularity

This package is not intended for wide use. It provides a temporary API to solve the problem: "Given an object some generic type A, how do I construct an instance of generic type B with the same type argument(s)?" This is necessary in a few rare places in order to migrate existing code to Dart 2's stronger type system. Eventually, the hope is to have direct language support for solving this problem but we don't have time to get that into 2.0, so this package is provided as a temporary workaround. We will very likely remove support for this in a later version of Dart.

Repository (GitHub)
View/report issues

Uploaders

rnystrom@google.com
nshahan@google.com

License

BSD (LICENSE)

More

Packages that depend on dart_internal