collection 1.15.0-nullsafety.2

Collections and utilities functions and classes related to collections.

86
likes
10 / 100
pub points
100 %
popularity

We analyzed this package on Oct 19, 2020, and awarded it 10 pub points (of a possible 100):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Sdk-constraint doesn't allow future stable dart 2.x releases

pubspec.yaml:8:8

  ╷
8 │   sdk: '>=2.10.0-0 <2.10.0'
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 10

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 197 issues. Showing the first 2:

ERROR: This requires the 'non-nullable' language feature to be enabled.

lib/src/algorithms.dart:20:24

   ╷
20 │     {int Function(T, T)? compare}) {
   │                        ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/algorithms.dart

ERROR: This requires the 'non-nullable' language feature to be enabled.

lib/src/algorithms.dart:50:67

   ╷
50 │ int lowerBound<T>(List<T> sortedList, T value, {int Function(T, T)? compare}) {
   │                                                                   ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/algorithms.dart

Support up-to-date dependencies
0 / 20

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 2.10.2. Cannot run `pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: '>=2.10.0-0 <2.10.0'
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 2.10.2.

pubspec.yaml:8:8

  ╷
8 │   sdk: '>=2.10.0-0 <2.10.0'
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (2.10.1)

pubspec.yaml:8:8

  ╷
8 │   sdk: '>=2.10.0-0 <2.10.0'
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵
86
likes
10
pub points
100%
popularity

Publisher

dart.dev

Collections and utilities functions and classes related to collections.

Homepage

License

BSD (LICENSE)

More

Packages that depend on collection