An ASN.1 Parser for Dart.
Encodes & decodes ASN1 using BER encoding.
There is just enough implementation here to get an LDAP client library working.
var s = new ASN1Sequence(); s.add( new ASN1Integer(23)); s.add( new ASN1OctetString('This is a test')); s.add( new ASN1Boolean(true)); // GET the BER Stream var bytes = s.encodedBytes; // decode var p = new ASN1Parser(bytes); var s2 = p.nextObject(); // s2 is a sequence...
Remove obsolete crypto dependency in tests.
Added PrintableString and UTC Time elements
Changes to support RSA Private key : PEM file
Add import "package:bignum/bignum.dart"; in asn1lib.dart
Add ASN1ObjectIdentifier class
Add OBJECT_IDENTIFIER in asn1constants.dart
Modify ASN1Parser._doPrimitive to take OBJECT_IDENTIFIER and NULL_TYPE into account
Modify ASN1Null add contructor ASN1Null.fromBytes
Modify ASN1Integer to support BigInteger
Modify asn1element_test.dart to test BigInteger case, and rsa private key test
Add test/resource folder to store rsa key for testing
Changes to support RSA public key : PEM file
Add ASN1BitString class : not sure how to handle bitstring when unused bits is not zero
Add BIT_STRING_TYPE in asn1constants.dart
Modify ASN1Parser._doPrimitive to take BIT_STRING_TYPE into account
Modify asn1element_test.dart to test rsa public key
- Removed Int64List dependency and use bignum's BigInteger instead
- Updates for dart 2
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: asn1lib: ^0.4.3
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Analysis issues and suggestions
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
Maintenance issues and suggestions
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.2.4 <2.0.0|